This project has moved and is read-only. For the latest updates, please go here.

how to start using it ?

Jan 11, 2010 at 7:59 AM

I have configured log2console by using fileappender.

I have gievn proper path to that file , but still it doesnt show anything in viewer?

Can you help me configure it out ?

Jan 11, 2010 at 8:09 PM

Are you sure that the file you use is correctly updated on the other hand, as a log or something similar?

Jan 12, 2010 at 6:31 AM

yes it updating correctly , and path is also correct , still i cant get visualization for it in log2console.

 

Feb 17, 2010 at 5:17 AM
Statyk7 wrote:

Are you sure that the file you use is correctly updated on the other hand, as a log or something similar?

Statyk7,

I have just downloaded your tool and would like to know how to configure this.

I am using log4net and I have already generated a log files from my project. I would like to use this tool to view the log contents. In the recievers section I gave the file name (including the complete path) of my log file in the "File to Watch" configuration. I am not able to view the contents of the log files.

Please advise if I am missing something ?

Regards,

Kaushik

Feb 17, 2010 at 5:38 AM

Hi!

i have find a way to run. But strange its not updated automatically.

First i have to stop Log2console application then again start to get effect.

Can you fix this behavior ?

Feb 22, 2010 at 3:27 PM
Edited Feb 22, 2010 at 3:29 PM

Hi,

I just learned to use log4net and I look at this program, the interface looks good! but, I also having the same problem. I already install the program, choose LogFile (Flat or Log4j...) Receiver and give the "File to Watch" path to my log file but it doesn't show anything. I am using Log4NET to generate my log file. This is the message from my log file:

WARN 2010-02-22 03:48:28 – sadi the great

WARN 2010-02-22 03:48:33 – sadi the great

WARN 2010-02-22 03:48:34 – sadi the great

WARN 2010-02-22 03:48:34 – sadi the great

WARN 2010-02-22 03:50:35 – sadi the great

DEBUG2010-02-22 03:50:35 – Wow

FATAL2010-02-22 03:50:35 – Extreme Danger

Can anyone tell me what I have done wrong?

Feb 23, 2010 at 2:53 AM

It looks like there is a bug in the FileReceiver actually... I'm going to investigate...

Thank you for your feedback!

Aug 3, 2010 at 1:29 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Sep 7, 2010 at 3:57 PM

I solved it by renaming the log filte from txt to xml extension. try it.

Sorry, but english is not my first language.